z·eeki·sh

tech log on gentoo, linux, and random stuff

Posts Tagged ‘xsetwacom

quick note on x61t tuxonice issues

leave a comment »

  1. dhcpcd dies after resume
    fix: add an OnResume entry in /etc/hibernateOnResume scripts

  2. stylus geometry messed up. also reproducible if
    • manually rotate to another direction by
      xrandr -o right && xsetwacom set stylus rotate CW

    • switch to some VT and back
    • now one or more of {Top/Bottom}{X/Y} is wrong

    there’s no problem if both xrandr and xsetwacom are in normal orientation, so probably a problem of wacom driver. Never realized it before as I’ve never switched to VT from tablet mode, but IIRC hibernate-script has this trick of switching to some ficticious VT and then back to ensure X is displayed on resume, and so the weird problem.

    fix: manually by DISPLAY=:0 xsetwacom set stylus xydefault for device named stylus, etc. . Here’s a script to reset all available devices:

    #!/bin/sh 
    # rst: reset tablet geometry 
    export DISPLAY=:0.0
    devices=`xsetwacom list dev | cut -f1 -d' '`
    for d in $devices; do
        xsetwacom set $d xydefault
    done

    I just bound it to the tiny little reset button on the tablet panel (keycode 199 as revealed by showkey) in actkbd.

    ## tiny little button, code 199
    199	:rep   :grab,noexec	:
    199	:rel   :grabbed,ungrab  :/home/bin/rst
    199	:rel   :ungrabbed	:/home/bin/rst
      

Written by zsh

April 1, 2009 at 11:05 pm

Posted in /etc

Tagged with , , , ,